Sophos Reporter Release Notes
Sophos Reporter 2.0.1.23 (2016-05-27)
  • Fixed issue where users could not be selected from a pick list in the Filters interface.
  • Fixed issue where duplicate categories may appear in the 'Unknown' productivity list in Settings | Productivity
  • Improvements to data record sanity checks making automatic data storage repairs more effective.

Sophos Reporter 2.0.1.22 (2016-05-17)
  • Added exception handling around host lookup for known syslog sources. Fixes the  'No such host is known' error you may see in Settings | Sources.
  • Includes latest Site Clean updates. New entries to Domain Substitues (including Quora, Instagram and Snapchat),  and Junk URLs.
  • Fixed GetSourceIPList API. 

Sophos Reporter 2.0.1.21 (2016-05-05)
  • Fixed issue where alerts with criteria based on Records, Session Time, Browsing Time were not firing.

Sophos Reporter 2.0.1.20 (2016-04-29)
  • LDAP import errors shown in the UI are now also logged in the Dashboard.log file.
  • Fixed issues displaying example data in Alert Evidence table when creating alerts.

Sophos Reporter 2.0.1.19 (2016-04-21)
  • Source IPs are now resolved to hostnames on import. ​If an authenticated username is logged, Fastvue Reporter will display their AD display name in reports. Otherwise it will display the resolved IP, or the original IP if it cannot be resolved.
  • Added autodetection of syslog traffic on UDP 514. When adding a source, any server sending UDP 514 traffic is available in a drop down list.
  • Added new Source Host field to use in Report filters and Alerts.
  • New API: System.FlushCaches() – Flushes resolved IPs out of all registered caches.

Sophos Reporter 2.0.1.18 (2016-04-14)
  • Test email function now correctly uses the 'From' address as specified in your Email Settings.
  • Fixed column width issue in Activity Reports.
  • LDAP import should no longer cause "Failed to log entry" errors when the directory entity being searched has a GUID in its FQDN.

Sophos Reporter 2.0.1.17 (2016-03-21)
  • Blank reports no longer produce an "index out of range" exception. If no records matched the specified report filter, or no records were read, a message is displayed in the report viewer indicating that the report is blank and provides a link to our support article on blank reports.
  • The width of columns in Activity Reports are calculated more intelligently to avoid squishing or hiding useful information.
  • Date picker is no longer obscured by the 'Activity over time' chart when a report is open.
  • When a report fails, the option to 'email the report when complete' is no longer shown.
  • Fixed the support portal link displayed in Settings | About.
  • Fixed display issues in the Alert editor.

Sophos Reporter 2.0.1.16 (2016-02-18)
  • Date picker validation tips no longer cover the date picker.
  • Added picklists for Site and Referrer Countries, Site and Referrer Protocols and Mime Types. 
  • Fields built from URLs such as Site Domain, Site Query etc now display tips on what values to enter.
  • Adding HTTP Status Code to the Alert Evidence Column now displays sample data in the example table.

Sophos Reporter 2.0.1.15 (2016-01-28)
  • Unhandled TAR/GZIP errors during import will now be reported as a source notification only once and cleared if the error is corrected.
  • Report and Alert Emails are now full width.
  • Added success/failure message when deleting LDAP Sources.
  • Fixed "Sequence contains no elements" error when registering.
  • The user count in Settings | Licensing | User Statistics now excludes machine accounts and combines User Login Names (domainusername) and User Principal Names (username@domain) into one user.
  • Installers now add a Windows Firewall exception for the Fastvue Sophos Reporter service on install.

Sophos Reporter 2.0.1.14 (2016-01-12)
  • Sophos UTM loader now handles duplicate syslog headers on lines (fixes an issue with end point protection syslog files)
  • Updated copyright year to 2016.