Reporter for ContentKeeper Release Notes
Reporter for ContentKeeper 1.0.1.19 (2016-05-27)
  • Resolving Source IPs is now only performed on records younger than 12 hours (limit is customised via the ResolveSourceHostsAgeLimit property in Settings.xml. Stop the service Fastvue Reporter service to make manual changes to this file).

Reporter for ContentKeeper 1.0.1.17 (2016-05-17)
  • Added exception handling around host lookup for known syslog sources. Fixes the  'No such host is known' error you may see in Settings | Sources.
  • Includes latest Site Clean updates. New entries to Domain Substitues (including Quora, Instagram and Snapchat),  and Junk URLs.
  • Fixed GetSourceIPList API. 

Reporter for ContentKeeper 1.0.1.16 (2016-05-05)
  • Fixed issue where alerts with criteria based on Records, Session Time, Browsing Time were not firing.

Reporter for ContentKeeper 1.0.1.15 (2016-04-29)
  • LDAP import errors shown in the UI are now also logged in the Dashboard.log file.
  • Fixed issues displaying example data in Alert Evidence table when creating alerts.

Reporter for ContentKeeper 1.0.1.14 (2016-04-21)
  • Added auto-detection of syslog traffic on UDP 514. When adding a source, any server sending UDP 514 traffic is available in a drop down list.
  • Source IPs are now resolved to hostnames on import.
  • Added New Field for "Source Host" to use in Report filters and Alerts.
  • New API: System.FlushCaches() – Flushes resolved IP out of all registered caches.
  • If an authenticated username is logged, Fastvue Reporter will display their AD display name in reports. Otherwise it will display the resolved IP, or the original IP if it cannot be resolved.

Reporter for ContentKeeper 1.0.1.13 (2016-04-14)
  • Test email function now correctly uses the 'From' address as specified in your Email Settings.
  • Fixed column width issue in Activity Reports.
  • LDAP import should no longer cause "Failed to log entry" errors when the directory entity being searched has a GUID in its FQDN.

Reporter for ContentKeeper 1.0.1.12 (2016-03-21)
  • Blank reports no longer produce an "index out of range" exception. If no records matched the specified report filter, or no records were read, a message is displayed in the report viewer indicating that the report is blank and provides a link to our support article on blank reports.
  • The width of columns in Activity Reports are calculated more intelligently to avoid squishing or hiding useful information.
  • Date picker is no longer obscured by the 'Activity over time' chart when a report is open.
  • When a report fails, the option to 'email the report when complete' is no longer shown.
  • Fixed the support portal link displayed in Settings | About.
  • Fixed display issues in the Alert editor.

Reporter for ContentKeeper 1.0.1.11 (2016-02-18)
  • Datepicker validation tips no longer cover the datepicker.
  • Added picklists for Site and Referrer Countries, Site and Referrer Protocols and Mime Types
  • Fields built from URLs such as Site Domain, Site Query etc now display tips on what values to enter.

Reporter for ContentKeeper 1.0.1.10 (2016-01-28)
  • Unhandled TAR/GZIP errors during import will now be reported as a source notification only once and cleared if the error is corrected.
  • Report and Alert Emails are now full width.
  • Added success/failure message when deleting LDAP Sources.
  • Fixed "Sequence contains no elements" error when registering.
  • The user count in Settings | Licensing | User Statistics now excludes machine accounts and combines User Login Names (domainusername) and User Principal Names (username@domain) into one user.
  • Installers now add a Windows Firewall exception for the "Fastvue Reporter for ContentKeeper" service on install.

Reporter for ContentKeeper 1.0.1.9 (2016-01-12)

Updated copyright year to 2016.